[fixed in 6.20b1860] Unable to insert web document..

Legacy MyInfo versions topics and topics that are no longer relevant
riderv3
Posts: 17
Joined: Thu Aug 15, 2013 5:07 am

[fixed in 6.20b1860] Unable to insert web document..

Post by riderv3 »

Hello,
I am using 6.20 pro build 1833, and I have noticed that when inserting a web document, the "save local copy" does not seem to work. Existing local copies of pages are ok, but when attempting to insert new web documents, it does not create a local copy, even when the checkbox is activated.

I have tried the "Store local copy of this web page" button on the toolbar, and the page refreshes, it does not work.

Please advise.

Thank you very much,
Gerald Rose
mirceglavni
Posts: 42
Joined: Fri Jan 27, 2012 7:21 am

Post by mirceglavni »

I can confirm this finding.

Furthermore, if you use the browser-addon (in my case, the addon for Firefox), it makes no difference whether you save it with "Send to MyInfo", or with "Send to MyInfo (Attachment)"
This used to be a problem some updates ago, was fixed and now is back again.
Petko
MyInfo Support
Posts: 3231
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

I can't reproduce any of the both problems with my setup. Which edition of MyInfo do you use (desktop/portable)? Could you give me an example URL which can't be stored locally or which is always pasted as attachment?
mirceglavni
Posts: 42
Joined: Fri Jan 27, 2012 7:21 am

Post by mirceglavni »

I am using the last build (1833), desktop version. Whatever I choose - Send to MyInfo or Send to MyInfo (Attachment), MyInfo always shows the internet-address in the address bar (ie http://www.....)

This happens with every web-page I tried to capture.
Petko
MyInfo Support
Posts: 3231
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

mirceglavni wrote:I am using the last build (1833), desktop version. Whatever I choose - Send to MyInfo or Send to MyInfo (Attachment), MyInfo always shows the internet-address in the address bar (ie http://www.....)

This happens with every web-page I tried to capture.
When you use either command in FF (Send as text/Send as attachment) and there is nothing selected in Firefox, is the following text inserted in the text editor under the web pane:
"Inserted from [some web address]"?

And another thing that can help: is there any difference whether you Send a whole web page or just a selection? Do they both fail to be stored locally?
mirceglavni
Posts: 42
Joined: Fri Jan 27, 2012 7:21 am

Post by mirceglavni »

This is kind of strange, I get different results from my work and my home desktop (both latest build):

Home Desktop:
Send to MyInfo, nothing selected on page: it gives a "live" web-page, meaning I see the page as it is in the browser, in the address bar I see the actual web-site address (http://www.....)

Send to MyInfo (Attachment), nothing selected on page: give me a saved version of the page (address bar says file:///C:/Users/....); however the page-output is garbage; it shows a outdated web-browser page (message from the web-site) - but with the live page (see above) - everything looks fine. The local copy is saved as a mht file - could this be the reason for the scrambled view?

Send to MyInfo, text selected: the selected text is entered into a new note, along with the message "Pasted from....web-site

Send to MyInfo (Attachment), text selected: NOTHING is entered into the upper window, in the lower windows I see the message "Inserted from ....web-site".


Situation on work computer: as described in my previous post - whatever I do, I always get the live web-page; although at work I did'nt try the "copy text first, then Send to MyInfo".

Some background info: Work: WinXP, SP3. Home: Win7, SP1.
Petko
MyInfo Support
Posts: 3231
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

mirceglavni wrote:Situation on work computer: as described in my previous post - whatever I do, I always get the live web-page; although at work I did'nt try the "copy text first, then Send to MyInfo".
Does it add "Inserted from [some web address]" in the text pane on your work computer when you send a whole web page as an attachment?
mirceglavni
Posts: 42
Joined: Fri Jan 27, 2012 7:21 am

Post by mirceglavni »

Yes it does, just checked it.
Petko
MyInfo Support
Posts: 3231
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

mirceglavni wrote:Yes it does, just checked it.
Could you write me a message at support@milenix.com from the email you used when purchasing MyInfo, so I can send you an updated version, which may fix the problem?
mirceglavni
Posts: 42
Joined: Fri Jan 27, 2012 7:21 am

Post by mirceglavni »

Petko, I've sent you an PM.
mirceglavni
Posts: 42
Joined: Fri Jan 27, 2012 7:21 am

Post by mirceglavni »

Petko, downloaded the updated build from the link you sent me.
Test on the WinXP, SP3 desktop PC. I cannot see any improvement:

1) Send to MyInfo from Firefox / no text selected on page: live version of web-page, address bar has the standard URL (http://www.) Notes windows is empty.

2) Send to MyInfo (Attachment) from Firefox / no text selected: again the live version of the web-page, but this time in the notes windows there is "Inserted from: name of the web-site

3) Send to MyInfo from Firefox with selected text: it pastes correctly the selected text and adds "Pasted from web-site name". It has only the window in the right pane - the normal notes window.

4) Send to MyInfo (Attachment) from Firefox with selected text: Here I get two windows; in the "Notes windows" it just says "Inserted from web-site name",in the "Embedded file window" I have the text I previously selected in Firefox. Interesting: in the address bar of the embedded file window the address is local (file:///C:/Documents and Settings/....../Web_page_fragment_7.mht.

Is this of any help?
Petko
MyInfo Support
Posts: 3231
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

Yes, this helps me to narrow the area where the problem might be. However, I need more info: when you click the Store Local Copy button on the toolbar for a live web site (for example http://www.milenix.com), does it show the "Updating local web page copy (hold ESC to cancel)" text in the status bar at least for a few seconds?

Also, could you try doing the following:
0. Exit MyInfo, if it is open.
1. Go to MyInfo installation folder (by default: C:\Program Files\Milenix\MyInfo 6)
2. Right click on ChilkatMHT.dll and from the context menu choose Open With > Choose Program > Open With > Select the Program From List, and click Ok.
3. Click Browse in the dialog that will appear.
4. In the file browsing dialog choose "regsvr32.exe", which should be located in C:\Windows\System 32
5. Click Open, then OK.

You should get the following message:
"DllRegisterServer in C:\Program Files\Milenix\MyInfo 6\ChilkatMHT.dll succeeded."

Now, start MyInfo and see if this resolves the problem.
mirceglavni
Posts: 42
Joined: Fri Jan 27, 2012 7:21 am

Post by mirceglavni »

Does it show "Updating local web page copy (hold ESC to cancel"?
No, it does not show anywhere, no matter if I previously captured the live page with Send to MyInfo or Send to MyInfo (Attachment).

I registered the ChilkaMHT.dll successfully with regsvr32.exe, started MyInfo again - still the same behaviour.

Testing on the work desktop (WinXP, SP3).

On a sidenote: in the live web-page, the mouse scroll wheel does not work; in the normal MyInfo documents it does work normally.
Petko
MyInfo Support
Posts: 3231
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

It should be fixed in the latest build.
renman
Posts: 2
Joined: Sat Jul 14, 2007 1:51 am

Post by renman »

Copy Paste/insert web document does not work me either using both explorer and or firefox.
Some info:
New Windows 7 PC box & install. I tried my version 5.05 on the new machine with the same results, being unable to copy paste in web import paste dialog box. Just upgraded to 6.20 build 1865. today. Same problem, no copy paste of web ink to dialog box. Copying data from a web page into myinfo does work, but not the web address. Help. Would build 1870 fix this and if so how do I access this link?
Clifford A Dickinson
Locked